Results 1 to 4 of 4

Thread: Arch Linux + Fluttercoin

  1. #1
    Senior Member kizeren's Avatar
    Join Date
    Sep 2014
    Posts
    109

    Arch Linux + Fluttercoin

    Per our discussion on skype. I found the last commit that works. a1cc39f62bf01901a690c474c34e9e25ae7b37d5
    as of commit 1850d2169cb3e248ca017a89247a4c2c95048774 is when things get funky.

    How I do the compile by hand method.

    cd ~/fluttercoin/src/
    make -f makefile.linux "take lunch break"
    Verify fluttercoind does work.
    cd ..
    qmake-qt4
    make "Dinner time and movie"
    then I just ./fluttercoin-qt

    Doesn't get much easier then that.


    My best guess is something in the last two commits broke my wallet, or is incompatible with ArchLinux now, or even possibly one of the packages that are installed on my system.

    Need any more info let me know.
    FTL F9Re35y9pgAtPXkXMfruxmQSES4bJvtpSK
    Bitmessage
    BM-2cUJdnCsXBHxktTp7i7EYAj4x11UL2BpWe Feel free to chat!

  2. #2
    Senior Member kizeren's Avatar
    Join Date
    Sep 2014
    Posts
    109
    Think I just found it. My current working version of fluttercoin-qt and fluttercoind are build with this version of clientversion.h

    #ifndef CLIENTVERSION_H
    #define CLIENTVERSION_H


    //
    // client versioning
    //


    // These need to be macros, as version.cpp's and bitcoin-qt.rc's voodoo requires it
    #define CLIENT_VERSION_MAJOR 0
    #define CLIENT_VERSION_MINOR 7
    #define CLIENT_VERSION_REVISION 5
    #define CLIENT_VERSION_BUILD 7


    // Converts the parameter X to a string after macro replacement on X has been performed.
    // Don't merge these into one macro!
    #define STRINGIZE(X) DO_STRINGIZE(X)
    #define DO_STRINGIZE(X) #X


    #endif // CLIENTVERSION_H


    This could explain the message of "Down grading my wallet". However the download for linux works fine on my wallet.
    But doesn't explain a fresh git clone with new wallet not working either.
    FTL F9Re35y9pgAtPXkXMfruxmQSES4bJvtpSK
    Bitmessage
    BM-2cUJdnCsXBHxktTp7i7EYAj4x11UL2BpWe Feel free to chat!

  3. #3
    Senior Member kizeren's Avatar
    Join Date
    Sep 2014
    Posts
    109
    Just verified on brand new Ubuntu 14.01 install. Everything compiles fine. Start fluttercoin-qt and after the flutterspeed is done it says "Error: Cannot downgrade wallet."
    FTL F9Re35y9pgAtPXkXMfruxmQSES4bJvtpSK
    Bitmessage
    BM-2cUJdnCsXBHxktTp7i7EYAj4x11UL2BpWe Feel free to chat!

  4. #4
    Senior Member kizeren's Avatar
    Join Date
    Sep 2014
    Posts
    109
    Reverting last commit 1850d2169cb3e248ca017a89247a4c2c95048774 the clientversion.h fixes the problem.
    FTL F9Re35y9pgAtPXkXMfruxmQSES4bJvtpSK
    Bitmessage
    BM-2cUJdnCsXBHxktTp7i7EYAj4x11UL2BpWe Feel free to chat!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •